Problem with WP-Stats-Dashboard Plugin “wp-content/plugins/wp-stats-dashboard/view/admin/graph.php” solved!

If you’re looking for a pretty slick WordPress stats package, you have to check out WP-Stats-Dashboard and the awesome functionality this brings to your admin dashboard.  As I toy around with this package, I am having a few issues I am slowly working on as I continue to re-import my tutorials back in to the site and look for missing images and errors.  One of the very first issues I had was when the package was first installed and instead of getting my trending graph reports, I would get one of the following two lines of text instead of a graph:

  1. ../wp-content/plugins/wp-stats-dashboard/view/admin/graph_trend.php
  2. ../wp-content/plugins/wp-stats-dashboard/view/admin/graph.php

I fiddled around with this for about 30 minutes, deleted and re-installed the plugin and tried a few other things to no avail… I ended up throwing my hands in the air in disgust and moved on to other things instead of wasting more time.  Well, turns out that was the right decision as it looks like this is an issue many folks are seeing when they first install the plugin.  How do you fix it?  Wait!  Yep, just wait for the graph to cache and it will start working all on its own… I came back to the WordPress dashboard a couple of hours later and VOILA, it started working.

So with that solved, I only have a couple of other issues:

  1. The WP-Stats-Dashboard iOS app looks awesome, but apparently Apple Store Canada does not carry the app… what the hell is that all about!?  I know there is a long tedious way to bypass this issue, but I’m too lazy to mess with it.  I’ve contacted Dave, the owner of WPSD so hopefully he can look in to this and start going international!
  2. When I go to the main WPSD stats dashboard, there is a box with all your social media metrics labeled “Stats – Social Media Metrics”.  When I click the reload button, it generates the following error: “Warning:  number_format() expects parameter 1 to be double, string given in ../wp-content/plugins/wp-stats-dashboard/classes/util/metrics/WPSDTechnoratiRank.php on line 59″. Now I have my WPSD set not to track Technorati so I have no idea why it is calling this page and why it’s generating an error.  I fiddled around with this as well and couldn’t find a solution.
  3. I’m also having a bit of an issue getting my social stats to track properly beyond Twitter and Facebook (Stumble, LinkedIn and G+ refuse to track) but I haven’t had a chance to mess with any of this yet.  I’m wondering if you need a paid account with LinkedIn for it to work.

Anyhow, hope this helps relax your nerves if you’re dealing with the graph.php issue and if you know the reason why my other 3 issues are happening, please feel free to chime in.

Thanks!
Dan